const regex = /\+\d{2}\s{1,9}\d{2}(?:\s{1,9})?\d{8}|\d{4}(?:\s{1,9}\d{6}(?:\d{4})?|\d(?:\s{1,9})?\d{6})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\+\\d{2}\\s{1,9}\\d{2}(?:\\s{1,9})?\\d{8}|\\d{4}(?:\\s{1,9}\\d{6}(?:\\d{4})?|\\d(?:\\s{1,9})?\\d{6})', 'gm')
const str = `+99 99 99999999
9999 999999
99999 999999
99999999999
+99 9999999999
9999 9999999999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}