package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\((?:[^()]|(?1))*\))$`)
var str = `(((()()())))
"some text (and words) more text (and words)
textrighthere(with some more)
little trickier (this time) with (all of (the)(values))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}