$re = '/(\((?:[^()]|(?1))*\))$/m';
$str = '(((()()())))
"some text (and words) more text (and words)
textrighthere(with some more)
little trickier (this time) with (all of (the)(values))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);