using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^-]+(?:-[^-]+)?).*";
string substitution = @"\1";
string input = @"60166213
60173866-4533
60167323-9439-1259801
NL170-2683-1262201
60174710-1-A12-4";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}