use strict;
my $str = '60166213
60173866-4533
60167323-9439-1259801
NL170-2683-1262201
60174710-1-A12-4';
my $regex = qr/([^-]+(?:-[^-]+)?).*/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";