# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^-]+(?:-[^-]+)?).*"
test_str = ("60166213\n"
"60173866-4533\n"
"60167323-9439-1259801\n"
"NL170-2683-1262201\n"
"60174710-1-A12-4")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.