#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^|})[^}{]*?\{([^}{]+?)\}(?=[^}]*$|[^}]*\{)"
Local $sString = "{amdnia91(+wowa}" & @CRLF & _
"{amdn{ia91(+wowa}" & @CRLF & _
".something{property:value;prop2:value}#something2{someprop:val;prop:val}" & @CRLF & _
".something{property:value{;prop2:value}#something2{someprop:val;prop:val}" & @CRLF & _
".something{property:v}alue;prop2:value}#something2{someprop:val;prop:val}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")