const regex = /(?<=^|})[^}{]*?\{([^}{]+?)\}(?=[^}]*$|[^}]*\{)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^|})[^}{]*?\\{([^}{]+?)\\}(?=[^}]*$|[^}]*\\{)', 'gm')
const str = `{amdnia91(+wowa}
{amdn{ia91(+wowa}
.something{property:value;prop2:value}#something2{someprop:val;prop:val}
.something{property:value{;prop2:value}#something2{someprop:val;prop:val}
.something{property:v}alue;prop2:value}#something2{someprop:val;prop:val}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}