using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^|})[^}{]*?\{([^}{]+?)\}(?=[^}]*$|[^}]*\{)";
string input = @"{amdnia91(+wowa}
{amdn{ia91(+wowa}
.something{property:value;prop2:value}#something2{someprop:val;prop:val}
.something{property:value{;prop2:value}#something2{someprop:val;prop:val}
.something{property:v}alue;prop2:value}#something2{someprop:val;prop:val}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}