package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\S\r\n]{2,}[A-Z]\w*(?:[^\S\r\n]\w+)*[^\S\r\n]{2,}`)
var str = `"As discussed in chapter 1, the users of financial statements can be categorised as resource provider. Users and decision making An example for this. Nature and purpose of financial analysis We have identi fied that financial analysis mvolves expressing reported numbers in financial statements in relative terms. "`
var substitution = "\n$&\t\t"
fmt.Println(re.ReplaceAllString(str, substitution))
}