# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^\S\r\n]{2,}[A-Z]\w*(?:[^\S\r\n]\w+)*[^\S\r\n]{2,}"
test_str = "\"As discussed in chapter 1, the users of financial statements can be categorised as resource provider. Users and decision making An example for this. Nature and purpose of financial analysis We have identi fied that financial analysis mvolves expressing reported numbers in financial statements in relative terms. \""
subst = "\\n$&\\t\\t"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.