const regex = /[^\S\r\n]{2,}[A-Z]\w*(?:[^\S\r\n]\w+)*[^\S\r\n]{2,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\S\\r\\n]{2,}[A-Z]\\w*(?:[^\\S\\r\\n]\\w+)*[^\\S\\r\\n]{2,}', 'g')
const str = `"As discussed in chapter 1, the users of financial statements can be categorised as resource provider. Users and decision making An example for this. Nature and purpose of financial analysis We have identi fied that financial analysis mvolves expressing reported numbers in financial statements in relative terms. "`;
const subst = `\n$&\t\t`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);