import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=((CAN|NUL|E(?:TX|NQ|SC)|S(?:OH|UB))(?:(?!\\2).)*))";
final String string = "3NUL<123>lkjasdf lfdl;kja (432) adsfa sd 4ETX<342> sdfasdf asfds asdfa4(1 234) \n\n"
+ "4ETX<345> asdfasdf\n\n"
+ "NULSOH<342> sadfasd fasasdf asd 4ETX<345> asdfasdf ";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}