import Foundation
let pattern = #"(?=((CAN|NUL|E(?:TX|NQ|SC)|S(?:OH|UB))(?:(?!\2).)*))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
3NUL<123>lkjasdf lfdl;kja (432) adsfa sd 4ETX<342> sdfasdf asfds asdfa4(1 234)
4ETX<345> asdfasdf
NULSOH<342> sadfasd fasasdf asd 4ETX<345> asdfasdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)