re = /(?=((CAN|NUL|E(?:TX|NQ|SC)|S(?:OH|UB))(?:(?!\2).)*))/
str = '3NUL<123>lkjasdf lfdl;kja (432) adsfa sd 4ETX<342> sdfasdf asfds asdfa4(1 234)
4ETX<345> asdfasdf
NULSOH<342> sadfasd fasasdf asd 4ETX<345> asdfasdf '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end