using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*\(\s*(?:'[-\/a-zA-Z 0-9]{1,40}')\,\s*\s*(?:'[-\/a-zA-Z 0-9]{1,40}')\,\s*(?:'[ifbIFB]{1}')\,\s*(?:'[0-9]{8}')\,\s*(?:'[0-9]{8}')\)\s*\,\s*\n*";
string input = @"('BAR', 'BARCGB22XXX', 'B', '00010101', '99991231'),
('BARC LON', 'BARCGB22XXX', 'B', '00010101', '99991231'),
('BARC-OTC', 'BARCGB22XXX', 'B', '00010101', '99991231'),
('BARINTL', 'BARCGB33XXX', 'B', '00010101', '99991231'),
('BCIEXUS', 'MLPFUS31XXX', 'B', '00010101', '99991231')";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}