re = /\s*\(\s*(?:'[-\/a-zA-Z 0-9]{1,40}')\,\s*\s*(?:'[-\/a-zA-Z 0-9]{1,40}')\,\s*(?:'[ifbIFB]{1}')\,\s*(?:'[0-9]{8}')\,\s*(?:'[0-9]{8}')\)\s*\,\s*\n*/
str = '(\'BAR\', \'BARCGB22XXX\', \'B\', \'00010101\', \'99991231\'),
(\'BARC LON\', \'BARCGB22XXX\', \'B\', \'00010101\', \'99991231\'),
(\'BARC-OTC\', \'BARCGB22XXX\', \'B\', \'00010101\', \'99991231\'),
(\'BARINTL\', \'BARCGB33XXX\', \'B\', \'00010101\', \'99991231\'),
(\'BCIEXUS\', \'MLPFUS31XXX\', \'B\', \'00010101\', \'99991231\')'
# Print the match result
str.match(re) do |match|
puts match.to_s
end