import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*\\(\\s*(?:'[-\\/a-zA-Z 0-9]{1,40}')\\,\\s*\\s*(?:'[-\\/a-zA-Z 0-9]{1,40}')\\,\\s*(?:'[ifbIFB]{1}')\\,\\s*(?:'[0-9]{8}')\\,\\s*(?:'[0-9]{8}')\\)\\s*\\,\\s*\\n*";
final String string = "('BAR', 'BARCGB22XXX', 'B', '00010101', '99991231'), \n"
+ "('BARC LON', 'BARCGB22XXX', 'B', '00010101', '99991231'), \n"
+ "('BARC-OTC', 'BARCGB22XXX', 'B', '00010101', '99991231'), \n"
+ "('BARINTL', 'BARCGB33XXX', 'B', '00010101', '99991231'), \n"
+ "('BCIEXUS', 'MLPFUS31XXX', 'B', '00010101', '99991231')";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}