using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[™®'é�’–â€]|\(TM\)|\(R\))";
string substitution = @"";
string input = @"asdasd as dsad â„¢xvdvfdgv(TM)fdsfsdfsf(R)dfsdfds";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}