// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:[™®'é�’–â€]|\(TM\)|\(R\))").unwrap();
let string = "asdasd as dsad â„¢xvdvfdgv(TM)fdsfsdfsf(R)dfsdfds";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}