const regex = /(?:[™®'é�’–â€]|\(TM\)|\(R\))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[™®\'é�’–â€]|\\(TM\\)|\\(R\\))', 'g')
const str = `asdasd as dsad â„¢xvdvfdgv(TM)fdsfsdfsf(R)dfsdfds`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);