using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^|\G(([a-z])\2?)";
string input = @"a.txt
aa.txt
baa.txt
bbaa.txt
cbbaa.txt
ccbbaa.txt
dccbbaa.txt
ddccbbaa.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}