import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^|\\G(([a-z])\\2?)";
final String string = "a.txt\n"
+ "aa.txt\n"
+ "baa.txt\n"
+ "bbaa.txt\n"
+ "cbbaa.txt\n"
+ "ccbbaa.txt\n"
+ "dccbbaa.txt\n"
+ "ddccbbaa.txt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}