$re = '/^|\G(([a-z])\2?)/m';
$str = 'a.txt
aa.txt
baa.txt
bbaa.txt
cbbaa.txt
ccbbaa.txt
dccbbaa.txt
ddccbbaa.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);