import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x) \n"
+ "\\d+ # at least one digit\n"
+ "\\. # a period\n"
+ "\\s # a space\n"
+ "[^\\d]+ # not a digit, 1 or more of them\n"
+ "\\s+ # a space, 1 or more of them\n";
final String string = " 1. Which is your primary browser for development 2. Which of the following technologies have you made use of? 2. Which of the following technologies have you made use of? 3. How old ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}