re = /(?x)
\d+ # at least one digit
\. # a period
\s # a space
[^\d]+ # not a digit, 1 or more of them
\s+ # a space, 1 or more of them
/
str = ' 1. Which is your primary browser for development 2. Which of the following technologies have you made use of? 2. Which of the following technologies have you made use of? 3. How old '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end