const regex = /(?x)
\d+ # at least one digit
\. # a period
\s # a space
[^\d]+ # not a digit, 1 or more of them
\s+ # a space, 1 or more of them
/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?x)
\\d+ # at least one digit
\\. # a period
\\s # a space
[^\\d]+ # not a digit, 1 or more of them
\\s+ # a space, 1 or more of them
', 'g')
const str = ` 1. Which is your primary browser for development 2. Which of the following technologies have you made use of? 2. Which of the following technologies have you made use of? 3. How old `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}