import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div id=[\\'|\"]content[\\'|\"][^>]*>(.*)<\\/div>";
final String string = "<div id=\"content\">\n"
+ " <div>\n"
+ " <div class=\"col-image\"></div>\n"
+ " THIS CONTENT HERE DOES NOT GET CAPTURED\n"
+ " </div>\n"
+ "</div>\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.UNICODE_CHARACTER_CLASS | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}