// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?sUi)<div id=[\'|"]content[\'|"][^>]*>(.*)<\/div>"#).unwrap();
let string = "<div id=\"content\">
<div>
<div class=\"col-image\"></div>
THIS CONTENT HERE DOES NOT GET CAPTURED
</div>
</div>
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}