$re = '/<div id=[\'|"]content[\'|"][^>]*>(.*)<\/div>/sUi';
$str = '<div id="content">
<div>
<div class="col-image"></div>
THIS CONTENT HERE DOES NOT GET CAPTURED
</div>
</div>
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);