#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([+-]?[^-+]+)"
Local $sString = "2x^3+4x^2+5x-42"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)