$re = '/([+-]?[^-+]+)/';
$str = '2x^3+4x^2+5x-42';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;