use strict;
my $str = '2x^3+4x^2+5x-42';
my $regex = qr/([+-]?[^-+]+)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";