$re = '~{"token":"(...)~';
$str = '<input data-val="true" data-val-required="Name is required" id="BillingAddress_Name" name="BillingAddress.Name" type="hidden" value="Testuser1" />
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);