// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"{"token":"(...)"#).unwrap();
let string = "<input data-val=\"true\" data-val-required=\"Name is required\" id=\"BillingAddress_Name\" name=\"BillingAddress.Name\" type=\"hidden\" value=\"Testuser1\" />
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}