re = /{"token":"(...)/
str = '<input data-val="true" data-val-required="Name is required" id="BillingAddress_Name" name="BillingAddress.Name" type="hidden" value="Testuser1" />
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end