$re = '/^(.*?)?( Com:.*)?$/m';
$str = ' Com: 123
abc Com: 123
abc
abc Com:123
abcCom:123
Com:123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);