using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(?:\(\{[^/]*/\s*/\s*}\)|NULL)\s*";
string substitution = @" ";
string input = @"NULL ({ / / }) Regina ({ 4 p1 p2 / / }) Shueller ({ 5 p1 p2 / / }) works ({ / / }) for ({ / / }) Italy ({ 14 / / }) 's ({ 15 / / }) La ({ 16 / / }) Repubblica ({ 17 / / }) newspaper ({ 18 / / }) . ({ 38 / / })";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}