// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s*(?:\(\{[^/]*/\s*/\s*}\)|NULL)\s*").unwrap();
let string = "NULL ({ / / }) Regina ({ 4 p1 p2 / / }) Shueller ({ 5 p1 p2 / / }) works ({ / / }) for ({ / / }) Italy ({ 14 / / }) 's ({ 15 / / }) La ({ 16 / / }) Repubblica ({ 17 / / }) newspaper ({ 18 / / }) . ({ 38 / / })";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}