re = /\s*(?:\(\{[^\/]*\/\s*\/\s*}\)|NULL)\s*/
str = 'NULL ({ / / }) Regina ({ 4 p1 p2 / / }) Shueller ({ 5 p1 p2 / / }) works ({ / / }) for ({ / / }) Italy ({ 14 / / }) \'s ({ 15 / / }) La ({ 16 / / }) Repubblica ({ 17 / / }) newspaper ({ 18 / / }) . ({ 38 / / })'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result