const regex = /(?<=if \(|elseif )\$\{([^}]*)\}([+-])\$\{([^}]*)\}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=if \\(|elseif )\\$\\{([^}]*)\\}([+-])\\$\\{([^}]*)\\}', 'gm')
const str = `<#if (\${val1}-\${val2}) + \${f1(\${a}+\${b}*\${c})} > 2000>ABC<#elseif \${n1}+\${n2}* \${f1(\${n3}-\${n4})} < 500>DEF</#if>`;
const subst = `\1\2\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);