$re = '/(?<=if \(|elseif )\$\{([^}]*)\}([+-])\$\{([^}]*)\}/m';
$str = '<#if (${val1}-${val2}) + ${f1(${a}+${b}*${c})} > 2000>ABC<#elseif ${n1}+${n2}* ${f1(${n3}-${n4})} < 500>DEF</#if>';
$subst = "\1\2\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;