use strict;
my $str = '<#if (${val1}-${val2}) + ${f1(${a}+${b}*${c})} > 2000>ABC<#elseif ${n1}+${n2}* ${f1(${n3}-${n4})} < 500>DEF</#if>';
my $regex = qr/(?<=if \(|elseif )\$\{([^}]*)\}([+-])\$\{([^}]*)\}/mp;
my $subst = '\\1\\2\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";