package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`(?m)--theme-display-name\s?:\s?["']?(.+)["';]`)
    var str = `:root {
  --theme-display-name: "Foo Bar";
  --theme-display-name: Foo;
  --theme-display-name : 'Foo Bar';
}`
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}