$re = '`--theme-display-name\s?:\s?["\']?(.+)["\';]`m';
$str = ':root {
--theme-display-name: "Foo Bar";
--theme-display-name: Foo;
--theme-display-name : \'Foo Bar\';
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);