re = /--theme-display-name\s?:\s?["']?(.+)["';]/m
str = ':root {
--theme-display-name: "Foo Bar";
--theme-display-name: Foo;
--theme-display-name : \'Foo Bar\';
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end