use strict;
my $str = '###################### Valid Emails ########################################################
######################## German, Austrian, international ###################################
janedoe@web.de
jane.doe@web.de
jdoe@web.de
jane-doe@web.de
jane@web.de
doe@web.de
janed@web.de
doej@web.de
jane_doe@web.de
j.doe@web.de
jane.d@web.de
janedoe@t-online.de
jane.doe@t-online.de
jdoe@t-online.de
jane-doe@t-online.de
jane@t-online.de
janed@t-online.de
doej@t-online.de
jane_doe@t-online.de
j.doe@t-online.de
jane.d@t-online.de
janedoe@hotmail.de
jane.doe@hotmail.de
jdoe@hotmail.de
jane-doe@hotmail.de
janedoe@gmx.de
jane.doe@gmx.de
jdoe@gmx.de
jane-doe@gmx.de
jane.doe@post.at
jane-doe@post.at
janedoe@post.at
jane@post.at
john.doe@austrian.com
horneaudrey@fulbright.at
#####################################################################################
########################## Not valid email ##########################################
.test@gmail.com
-test@gmail.com
t.-.est@gmail.com
.test.@gmail.com
test.@gmail.com
test.@.gmail.com
test@.gmail.com
test@.gmail.com.
test@gmail.com.
"email"@example.com
#@%^%#$@#$@#.com
@example.com
Joe Smith <email@example.com>
email.example.com
email@example@example.com
.email@example.com
email.@example.com
email..email@example.com
あいうえお@example.com
email@example.com (Joe Smith)
email@example
email@-example.com
email@example.web
email@111.222.333.44444
email@example..com
Abc..123@example.com';
my $regex = qr/^[a-z0-9]+[\._]?[a-z0-9]+[@]\w+[.]\w{2,3}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}