import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(/dev/[\\S]+|zroot\\S*?) on (/.*) \\(([a-zA-Z0-9]+), .+, (.+)\\)$";
final String string = "ZFS filesystem\n\n"
+ "zroot on / (zfs, local, nfsv4acls)\n"
+ "zroot/tmp on /tmp (zfs, local, nosuid, nfsv4acls)\n"
+ "zroot/usr on /usr (zfs, local, nfsv4acls)\n"
+ "zroot/usr/home on /usr/home (zfs, local, nfsv4acls)\n"
+ "zroot/usr/home/vagrant on /usr/home/vagrant (zfs, local, nfsv4acls)\n"
+ "zroot/usr/ports on /usr/ports (zfs, local, nosuid, nfsv4acls)\n"
+ "zroot/usr/ports/distfiles on /usr/ports/distfiles (zfs, local, noexec, nosuid, nfsv4acls)\n"
+ "zroot/usr/ports/packages on /usr/ports/packages (zfs, local, noexec, nosuid, nfsv4acls)\n"
+ "zroot/usr/src on /usr/src (zfs, local, noexec, nosuid, nfsv4acls)\n"
+ "zroot/var on /var (zfs, local, nfsv4acls)\n"
+ "zroot/var/crash on /var/crash (zfs, local, noexec, nosuid, nfsv4acls)\n"
+ "zroot/var/db on /var/db (zfs, local, noexec, nosuid, nfsv4acls)\n"
+ "zroot/var/db/pkg on /var/db/pkg (zfs, local, nosuid, nfsv4acls)\n"
+ "zroot/var/empty on /var/empty (zfs, local, noexec, nosuid, read-only, nfsv4acls)\n"
+ "zroot/var/log on /var/log (zfs, local, noexec, nosuid, nfsv4acls)\n"
+ "zroot/var/mail on /var/mail (zfs, local, noexec, nosuid, nfsv4acls)\n"
+ "zroot/var/run on /var/run (zfs, local, noexec, nosuid, nfsv4acls)\n"
+ "zroot/var/tmp on /var/tmp (zfs, local, nosuid, nfsv4acls)\n\n"
+ "Non ZFS filesystem\n\n"
+ "/dev/mfid0p2 on / (ufs, local, journaled soft-updates)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}