# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(/dev/[\S]+|zroot\S*?) on (/.*) \(([a-zA-Z0-9]+), .+, (.+)\)$"
test_str = ("ZFS filesystem\n\n"
"zroot on / (zfs, local, nfsv4acls)\n"
"zroot/tmp on /tmp (zfs, local, nosuid, nfsv4acls)\n"
"zroot/usr on /usr (zfs, local, nfsv4acls)\n"
"zroot/usr/home on /usr/home (zfs, local, nfsv4acls)\n"
"zroot/usr/home/vagrant on /usr/home/vagrant (zfs, local, nfsv4acls)\n"
"zroot/usr/ports on /usr/ports (zfs, local, nosuid, nfsv4acls)\n"
"zroot/usr/ports/distfiles on /usr/ports/distfiles (zfs, local, noexec, nosuid, nfsv4acls)\n"
"zroot/usr/ports/packages on /usr/ports/packages (zfs, local, noexec, nosuid, nfsv4acls)\n"
"zroot/usr/src on /usr/src (zfs, local, noexec, nosuid, nfsv4acls)\n"
"zroot/var on /var (zfs, local, nfsv4acls)\n"
"zroot/var/crash on /var/crash (zfs, local, noexec, nosuid, nfsv4acls)\n"
"zroot/var/db on /var/db (zfs, local, noexec, nosuid, nfsv4acls)\n"
"zroot/var/db/pkg on /var/db/pkg (zfs, local, nosuid, nfsv4acls)\n"
"zroot/var/empty on /var/empty (zfs, local, noexec, nosuid, read-only, nfsv4acls)\n"
"zroot/var/log on /var/log (zfs, local, noexec, nosuid, nfsv4acls)\n"
"zroot/var/mail on /var/mail (zfs, local, noexec, nosuid, nfsv4acls)\n"
"zroot/var/run on /var/run (zfs, local, noexec, nosuid, nfsv4acls)\n"
"zroot/var/tmp on /var/tmp (zfs, local, nosuid, nfsv4acls)\n\n"
"Non ZFS filesystem\n\n"
"/dev/mfid0p2 on / (ufs, local, journaled soft-updates)\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.