$re = '/.*http:.*/';
$str = '//this line should be ignored http://foo.com
NSString *url = @"http://foo.com"; //this line should show up as a result';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);